Past incidents Return to status page
Outlook 365 inboxes are unavailable for some customers
Incident Report for HubSpot
Resolved
Outlook 365 inboxes connected to HubSpot are now fully accessible. We've identified and addressed the root cause of the issue. The incident has been fully resolved and sending and syncing should be working properly. No data was lost.
Posted Apr 12, 2023 - 19:39 EDT
Monitoring
We've addressed the issue that caused some Outlook 365 inboxes to be unavailable since 4:00 AM EDT (UTC -04:00) on Apr 12, 2023. We're monitoring performance closely to ensure the tools recover properly.
Posted Apr 12, 2023 - 16:10 EDT
Identified
We've identified the issue that's caused some Outlook 365 inboxes to be unavailable since 4:00 AM EDT (UTC -04:00) on Apr 12, 2023. We're addressing the cause of this issue and will update this page when we have more information.
Posted Apr 12, 2023 - 13:45 EDT
Update
Microsoft Outlook 365 inboxes connected to HubSpot are experiencing issues sending and syncing email right now. We're investigating what's causing this issue and will update this page when we have more information.
Posted Apr 12, 2023 - 13:02 EDT
Investigating
Microsoft Outlook 365 inboxes connected to HubSpot are experiencing issues sending email right now. We're investigating what's causing this issue and will update this page when we have more information.
Posted Apr 12, 2023 - 12:22 EDT
This incident affected: Sales Tools, Service Tools, and Integrations.