Past incidents Return to status page
Issue loading Deals in HubSpot CRM
Incident Report for HubSpot
Resolved
Between 1:50PM and 2:05 PM, some timeouts occurred while loading Deals in in the CRM. Engineering has addressed the immediate cause, and is putting further safeguards in place.
Posted Aug 17, 2016 - 14:54 EDT