Past incidents Return to status page
Email event data processing is currently delayed for all customers
Incident Report for HubSpot
Resolved
Processing of email event data in HubSpot is now fully operational. We’ve identified and addressed the cause of the issue. No email event data was lost as a result of this issue. Customers may have seen delays to list enrollment, workflow enrollment or workflow branching that depended on email data such as clicks and opens.

The incident has now been fully resolved.
Posted Apr 09, 2020 - 10:48 EDT
Update
We’ve addressed the issue that caused the processing of email event data in HubSpot to be delayed since 7:06 am ET on Thursday, April 9, 2020. We are currently processing a backlog of data and are seeing delays continue to decrease. We’re monitoring performance to ensure all email events are processed completely.
Posted Apr 09, 2020 - 10:15 EDT
Monitoring
We are continuing to process delayed email event data in HubSpot. Currently, we are seeing delays of up to 80 minutes and are actively working to address the cause of this issue. We will update this page when more information is available.
Posted Apr 09, 2020 - 10:08 EDT
Identified
We’ve identified the issue that caused the processing of email event data in HubSpot to be delayed since 7:06 am ET on Thursday, April 9, 2020. Currently, we are seeing delays of up to 90 minutes. We’re addressing the cause of this issue and will update this page when more information is available.
Posted Apr 09, 2020 - 09:12 EDT
Investigating
Processing of email event data in HubSpot is experiencing delays of up to 1 hour. This includes Marketing Email data such as sends, opens and clicks, and Conversations Email bounce data. We’re investigating the cause of this issue and will update this page when more information is available.
Posted Apr 09, 2020 - 08:44 EDT
This incident affected: Marketing Tools, Sales Tools, and Service Tools.