Past incidents Return to status page
Meetings tool is unavailable for some customers
Incident Report for HubSpot
Resolved
The HubSpot Meetings tool is now fully accessible. We’ve identified the cause of the issue as an outage with Google Calendar. The incident has been fully resolved and your Meetings pages should be functioning properly now.
Posted Nov 11, 2019 - 06:31 EST
Monitoring
HubSpot public meeting pages are now loading and users are able to connect their Google calendars to the Meetings app. We are continuing to monitor the issue.
Posted Nov 11, 2019 - 06:13 EST
Investigating
The Meetings app isn’t available right now. We’re investigating reports of a Google Calendar outage and will update this page when more information is available.
Posted Nov 11, 2019 - 06:06 EST
This incident affected: Sales Tools.