Past incidents Return to status page
The HubSpot software is intermittently unavailable for some customers
Incident Report for HubSpot
Resolved
HubSpot software is now working for all users and the incident has now been fully resolved.
Posted Jun 21, 2022 - 04:28 EDT
Update
Our third-party CDN provider, Cloudflare, has addressed the issue that’s been preventing HubSpot software from loading. We’re monitoring performance to ensure the app recovers properly.

There are still some delays in process recovery across affected regions, however most processes, including login, should be stabilising.
Posted Jun 21, 2022 - 03:35 EDT
Monitoring
HubSpot is currently unavailable. We’ve identified the cause of widespread internet unavailability and delays with our third-party content delivery network provider, Cloudflare.

Cloudflare has reported a fix was implemented to an issue causing widespread internet unavailability and delays. We’re monitoring closely to ensure all processes recover properly in affected regions.

Learn More on Cloudflare Status Page
https://www.cloudflarestatus.com/
Posted Jun 21, 2022 - 03:17 EDT
This incident affected: CRM, Marketing Tools, Sales Tools, and Service Tools.