It is not possible to edit notes, call & meeting activity, and tasks on mobile.
Incident Report for HubSpot
Resolved
We have now resolved this issue. It's not necessary to update your app to get the fix because the fix has been automatically applied to all accounts.

However, you should still upgrade to the new version of the iOS app when it becomes available because it contains other improvements too.
Posted 2 months ago. Apr 16, 2019 - 11:08 EDT
Monitoring
We have released a new version of our Android app, which fixes this issue. The new version is 2.0.781 and is rolling out now across the Google Play Store. It may take a couple of hours to become available to you.

We have also submitted a new version of our iOS app, which fixes this issue, to Apple for review. The new version is 3.1.256. Once it has been approved by Apple, it will become available in the App Store. This typically takes 1-2 days.
Posted 2 months ago. Apr 15, 2019 - 16:56 EDT
Identified
We have identified a problem preventing users from editing notes, call & meeting activity, and tasks on Android and iOS. These can be created as usual, but editing text or marking tasks as complete will not be saved. We have identified a fix and are working on making it available in the next versions of our Android and iOS app.

We will update this incident once the new version of the HubSpot mobile app is available. Upgrading to the newer version will resolve the issue.
Posted 2 months ago. Apr 15, 2019 - 12:20 EDT
This incident affected: Mobile.