Past incidents Return to status page

HubSpot may be unavailable for some users

Incident Report for HubSpot

Resolved

HubSpot is now working for all users. We addressed the root cause of the issue that prevented CRM records from being created or updated, and the issue is fully resolved.
Posted 12 days ago. Mar 25, 2025 - 12:51 EDT

Monitoring

We have identified the cause of this issue. At this point, the ability to create and update CRM records has been restored. We will be back with an update within an hour.
Posted 12 days ago. Mar 25, 2025 - 12:18 EDT

Identified

We are continuing to investigate the root cause of an issue that is preventing users from creating or updating records in the CRM since 10:42 AM EDT (UTC -04:00) on Mar 25, 2025. We've identified a core service that is degraded and are working to address the performance issues now. We will be back with an update within 30 minutes.
Posted 12 days ago. Mar 25, 2025 - 11:59 EDT

Update

We are investigating an issue where some users are unable to create or update CRM objects due to persistent errors. This appears to be related to degraded performance in a core internal service. Early signs indicate that the issue may be isolated to our na1 datacenter. Our teams are working to identify the root cause and implement mitigations. At this time, there are no known workarounds. We will provide our next update by 16:00 UTC or sooner if new information becomes available. We apologize for the inconvenience and appreciate your patience as we work to resolve this issue. We will be back with an update within 30 minutes.
Posted 12 days ago. Mar 25, 2025 - 11:33 EDT

Investigating

We're investigating reports that HubSpot may be unavailable for some users. We'll update this page when we have more information.
Posted 12 days ago. Mar 25, 2025 - 11:26 EDT
This incident affected: CRM.