Past incidents Return to status page

Multiple apps are unavailable for some customers

Incident Report for HubSpot

Resolved

HubSpot is now working for all users. We identified and addressed the root cause of the issue that prevented HubSpot from loading, and the issue is fully resolved. No data was lost.
Posted Oct 20, 2025 - 06:45 EDT

Update

We've addressed the issue that caused multiple apps to be unavailable since 3:42 AM EDT (UTC -04:00) on Oct 20, 2025. We're monitoring performance closely to ensure the tools recover properly. We will be back with an update within 30 minutes.
Posted Oct 20, 2025 - 06:15 EDT

Monitoring

We've addressed the issue that prevented HubSpot from loading beginning at 3:42 AM EDT (UTC -04:00) on Oct 20, 2025. We're monitoring performance closely to ensure the software recovers properly. We will be back with an update within 30 minutes.
Posted Oct 20, 2025 - 05:33 EDT

Identified

We've identified the issue that's been preventing HubSpot software from loading since 3:42 AM EDT (UTC -04:00) on Oct 20, 2025. We're addressing the cause of this issue and will update this page when we have more information. We will be back with an update within 30 minutes.
Posted Oct 20, 2025 - 05:09 EDT

Update

We are investigating an issue impacting multiple HubSpot apps. We are working with our cloud platform provider, AWS, to resolve it.
Posted Oct 20, 2025 - 04:46 EDT

Investigating

Multiple apps aren't available right now. We're investigating what's causing this issue and will update this page when we have more information. We will be back with an update within 30 minutes.
Posted Oct 20, 2025 - 04:34 EDT