Past incidents Return to status page
"Send a test email" is presently experiencing delays or duplicate sends
Incident Report for HubSpot
Resolved
This incident has been resolved. Sending test emails is now working as expected.
Posted Apr 09, 2018 - 19:23 EDT
Identified
Sending a test email from HubSpot Marketing tools is not behaving as expected. Attempts to send a test send are either being delayed by up to 90 minutes, or are sending more than the expected one email. We have identified the issue and are working on a fix.
Posted Apr 09, 2018 - 19:12 EDT