Past incidents Return to status page
List processing is currently delayed by up to 40 minutes for accounts with more than 100,000 contacts
Incident Report for HubSpot
Resolved
This incident is fully resolved. All dynamic updates to list and workflow memberships should be processing as normal. The backlog has fully caught up. No data was lost as a result of this issue.
Posted Sep 20, 2018 - 13:29 EDT
Monitoring
We are still experiencing delays of up to 15 minutes for new list, workflow, and report creation in accounts with more than 100,000 contacts.

Dynamic list updates are back to normal. Contacts are now being added and removed from a list, and enrolled in workflows when they meet the criteria as expected.
Posted Sep 20, 2018 - 12:29 EDT
Identified
We’ve identified the issue that’s caused list processing within HubSpot accounts with more than 100,000 contacts to be delayed by 40 minutes. This impacts list creation and updates, workflow enrollments, as well as any cross-data reports that include contacts data. We’re actively addressing the cause of this issue and will update this page when more information is available.
Posted Sep 20, 2018 - 11:46 EDT
Investigating
We’ve identified an issue that’s caused list processing to be delayed by up to 40 minutes if there are a large number of contacts in the account (100,000 or more). If the list criteria is updated or a new list is saved, this may take up to 40 minutes to process. This also impacts Workflow enrollments, which will also be delayed. We’re actively addressing the cause of this issue and will update this page when more information is available.
Posted Sep 20, 2018 - 11:15 EDT