Past incidents Return to status page

Long load times across HubSpot

Incident Report for HubSpot

Resolved

HubSpot is now fully accessible. The incident has been fully resolved and HubSpot should be working properly. No data was lost.
Posted 1 month ago. Feb 05, 2025 - 17:05 EST

Monitoring

Cloudflare has implemented a fix. We’re monitoring performance closely to ensure the software recovers properly.
Posted 1 month ago. Feb 05, 2025 - 13:33 EST

Update

Cloudflare has implemented a fix. We’re monitoring performance closely to ensure the software recovers properly.
Posted 1 month ago. Feb 05, 2025 - 13:33 EST

Identified

A Cloudflare outage is causing long load times across HubSpot. Cloudfare has identified the issue and is working to resolve it:

https://www.cloudflarestatus.com/incidents/m90shgg0k4dd
Posted 1 month ago. Feb 05, 2025 - 12:09 EST
This incident affected: CRM, Marketing Tools, Website, Sales Tools, Service Tools, Chat & Automation, Reports, HubSpot APIs, Integrations, and Mobile.