Past incidents Return to status page
HubSpot Videos Failing to Load on HubSpot Hosted Content
Incident Report for HubSpot
Resolved
We have resolved an issue with our embed code that was causing HubSpot Videos to only load video thumbnails on HubSpot pages beginning at 2:45 PM EDT and ending at 4:35 PM EDT, all videos are loading properly at this time.
Posted Sep 24, 2018 - 16:53 EDT
Identified
We have identified an issue that is preventing some HubSpot Videos from properly loading on HubSpot pages beginning at 3:15 PM EDT. Impacted videos are currently loading only the image thumbnails. Our team is currently working on a fix and we will keep this page updated as more information becomes available.
Posted Sep 24, 2018 - 16:36 EDT
Investigating
We are currently investigating an issue that is preventing some HubSpot Videos from properly loading on HubSpot pages beginning at 3:15 PM EDT. Impacted videos are currently loading only the image thumbnails. We will update this status as more information becomes available.
Posted Sep 24, 2018 - 16:11 EDT