Past incidents Return to status page
CRM Call Queue Not Loading
Incident Report for HubSpot
Resolved
The CRM Call Queue is fully operational and the issue has been resolved.
Posted Jan 18, 2017 - 11:19 EST
Monitoring
We've addressed the cause of the issue and implemented a fix. Call Queue should be loading and functioning properly.
Posted Jan 18, 2017 - 11:02 EST
Identified
Our team has identified the issue and is working on a fix.
Posted Jan 18, 2017 - 10:42 EST
Investigating
We are currently experiencing a problem loading the Call Queue. Engineering is aware of the issue and is investigating.
Posted Jan 18, 2017 - 10:40 EST