We are currently experiencing a delay when loading CRM data.
Incident Report for HubSpot
Resolved
Everything is back to operational.
Posted 5 months ago. Mar 12, 2019 - 11:44 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Mar 12, 2019 - 11:38 EDT
Identified
This will impact CRM functionality including calling, associations and the loading of records
Posted 5 months ago. Mar 12, 2019 - 11:33 EDT
Investigating
We have been experiencing delays in loading Deals in all portals since 10:45 EST
Posted 5 months ago. Mar 12, 2019 - 11:25 EDT
This incident affected: HubSpot CRM, HubSpot APIs, and HubSpot Sales.