Past incidents Return to status page
Global search is currently experiencing intermittent failures for all portals
Incident Report for HubSpot
Resolved
This incident has been resolved.
Posted Oct 30, 2018 - 12:30 EDT
Investigating
Investigating
Global search in HubSpot is experiencing intermittent failures for all portals.
Posted Oct 30, 2018 - 10:58 EDT