Past incidents Return to status page
Some marketing email sends are delayed for over two hours
Incident Report for HubSpot
Resolved
All emais have now been sent. The incident is now resolved.
Posted Mar 05, 2018 - 19:43 EST
Monitoring
We have identified the cause of the delays. Most delayed sends have now completed. We are continuing to monitor the status of our email sends.
Posted Mar 05, 2018 - 19:34 EST
Investigating
Marketing email sends and some other email operations are presently delayed up to two hours. We’re actively investigating the cause of this issue and will update this page when more information is available.
Posted Mar 05, 2018 - 18:37 EST