Past incidents Return to status page
Form submissions are currently delayed for some customers
Incident Report for HubSpot
Resolved
Form submissions are no longer experiencing delays. We’ve identified and addressed the cause of the delays that began at 11:10 AM EST on October 11, 2022. The issue is now fully resolved. No data was lost.
Posted Oct 11, 2022 - 13:16 EDT
Monitoring
We’ve addressed the issue that caused delays in form submissions beginning at 11:10 AM EST on October 11, 2022. No data was lost. We’re monitoring performance closely to ensure the tools recover properly.
Posted Oct 11, 2022 - 13:11 EDT
Investigating
We’re investigating an issue causing delays in form submissions beginning at 11:10 EST on October 11, 2022. No data was lost. The submissions may take up to 90 minutes to show in HubSpot. Our team is addressing the cause of this issue and will update this page when the issue is resolved.
Posted Oct 11, 2022 - 12:50 EDT
This incident affected: Marketing Tools.