Past incidents Return to status page
Updates to HubSpot CRM are currently delayed for all customers
Incident Report for HubSpot
Resolved
This incident is now resolved. Any updates that were made during this issue have been backfilled and all updates to properties in the CRM should be displaying as expected. No data was lost as a result of this issue.
Posted May 14, 2018 - 15:19 EDT
Identified
We’ve identified an issue that’s causing updates in HubSpot CRM to be delayed. This impacts all updates to properties on contact, company, deal and ticket records. We’re actively addressing the cause of this issue and will update this page when more information is available.
Posted May 14, 2018 - 15:08 EDT