Past incidents Return to status page
Some CRM records may not appear in the board or list view
Incident Report for HubSpot
Resolved
This incident has been resolved.
Posted May 27, 2020 - 19:08 EDT
Monitoring
A fix has been implemented. We are monitoring the situation as the processing catches up.
Posted May 27, 2020 - 17:51 EDT
Identified
The issue has been identified and the fix is being put in place. We are seeing a drop in delays.
Posted May 27, 2020 - 17:45 EDT
Update
We are continuing to investigate this issue.
Posted May 27, 2020 - 17:44 EDT
Investigating
We have identified an issue causing some CRM data to not appear in the board and table views. Additionally, Lists may be delayed. No data has been lost. This issue has been occurring since 1pm ET. Our team is investigating this issue and will provide an update when more information is available.
Posted May 27, 2020 - 16:31 EDT
This incident affected: CRM.