Past incidents Return to status page
Some HubSpot features are currently experiencing delays
Incident Report for HubSpot
Resolved
On Friday, between 12:10 PM and 1:00 PM EDT, some HubSpot features experienced delays in processing. We identified the root cause as an issue with our provider Amazon Web Services. These delays impacted features such as lists, cross-object reports, email sends, and notifications, and are now resolved.
Posted Aug 14, 2020 - 14:05 EDT
Update
Some HubSpot features were experiencing delays between 12:10 PM and 1:00 PM EST. Our teams are monitoring all tools to ensure that all processing is caught up and will update this page as more information is available.
Posted Aug 14, 2020 - 13:16 EDT
Monitoring
Some HubSpot features were experiencing delays between 12:10 PM and 1:00 PM EST. Our teams are monitoring all tools to ensure that all processing is caught up and will update this page as more information is available.
Posted Aug 14, 2020 - 13:12 EDT
Update
Our team is continuing to work to identify the cause of the issue causing some delays across some HubSpot features. This may cause slow processing for HubSpot features such as imports, cross-object reports, lists, email sends, and notifications. We’ll update this page when we have more information.
Posted Aug 14, 2020 - 12:59 EDT
Update
We are continuing to investigate this issue.
Posted Aug 14, 2020 - 12:50 EDT
Investigating
Some HubSpot features are currently experiencing delays. This may cause slow processing for HubSpot features such as imports, cross-object reports, lists, email sends, and notifications. This can also cause slow loading of pages. Our team is working to identify the root cause of this issue and will update this page as soon as we're able to share more information.
Posted Aug 14, 2020 - 12:40 EDT
This incident affected: CRM, Marketing Tools, Sales Tools, Service Tools, Chat & Automation, Reports, HubSpot APIs, Integrations, and Mobile.