Past incidents Return to status page
Changes to content not displaying on live pages for some customers
Incident Report for HubSpot
Resolved
This incident has been resolved.
Posted Oct 29, 2019 - 12:58 EDT
Investigating
Edits made to landing pages, website pages, blog posts and knowledge base articles are not being reflected on live pages for some customers right now. We’re investigating the cause of this issue and will update this page when more information is available.
Posted Oct 29, 2019 - 12:19 EDT