Past incidents Return to status page
HubSpot logins are experiencing issues for some customers
Incident Report for HubSpot
Resolved
We've resolved the issue and HubSpot login is now functioning as expected. Customers may have been logged out and may need to login again to access HubSpot.
Posted Feb 26, 2021 - 16:54 EST
Monitoring
We’ve addressed the issue that caused customers to not be able to login from 3:37pm ET to 4:04pm ET and some HubSpot applications may have been inaccessible from 4:12pm ET to 4:26pm ET. We’re monitoring performance closely to ensure everything recovers properly. Customers may have been logged out and may need to login again to access HubSpot.
Posted Feb 26, 2021 - 16:46 EST
Identified
We’ve identified the issue that’s preventing HubSpot logins for some customers. We’re addressing the cause of this issue and will update this page when we have more information.
Posted Feb 26, 2021 - 16:18 EST