Past incidents Return to status page
HubSpot hosted pages are slow to load or unavailable for some customers
Incident Report for HubSpot
Resolved
We have resolved an issue with our servers that caused some HubSpot hosted pages to load slowly or fail to load for some customers beginning on 4/19/2018 at 8:11 AM EST. All content is now fully accessible.
Posted Apr 19, 2018 - 08:45 EDT
Monitoring
We have identified and are monitoring an issue that is causing some HubSpot hosted pages to load slowly or fail to load for some customers beginning on 4/19/2018 at 8:11 AM EST.
Posted Apr 19, 2018 - 08:31 EDT