Past incidents Return to status page
Delayed email processing
Incident Report for HubSpot
Resolved
All delayed email campaigns have been processed. All new campaigns are sending as expected.
Posted Sep 22, 2016 - 13:22 EDT
Identified
Email processing is delayed by up to 90 minutes. We've identified the cause and activated a workaround so we should see email delays reduce over the next hour or so
Posted Sep 22, 2016 - 12:44 EDT