Past incidents Return to status page
Lead Status property not loading on contact profiles for some customers
Incident Report for HubSpot
Resolved
We've identified and resolved the issue that was preventing the Lead Status property from loading on contact profiles for some users. Lead Status should be displaying properly now.
Posted Nov 06, 2018 - 14:32 EST
Investigating
We’re currently experiencing an issue that’s preventing the Lead Status property from loading on contact profiles for some users. We’re actively investigating the cause of this issue and will update this page when more information is available.
Posted Nov 06, 2018 - 13:57 EST