Past incidents Return to status page
Multiple HubSpot processes including logins and page loads is currently delayed for all customers
Incident Report for HubSpot
Resolved
Page loading and login is no longer experiencing delays. We've identified and addressed the cause of the delays that began at 10:18 AM EDT (UTC -04:00) on Sep 20, 2023 as a problem with an internal database. The issue is now fully resolved.
Posted Sep 20, 2023 - 11:11 EDT
Monitoring
We've addressed the issue that was causing delayings in page loading and login delays of up to 3 minutes starting at 10:18 AM EDT (UTC -04:00) on Sep 20, 2023. We're monitoring the tools closely to ensure all processes recover properly.
Posted Sep 20, 2023 - 10:51 EDT
Identified
We've identified the cause of delays to multiple HubSpot processes, including logins and page loading. Users may experience delays of up to 3 min since 10:18 AM EDT (UTC -04:00) on Sep 20, 2023. These delays may impact tools such as Calling, CRM, and Login in HubSpot. Our team is investigating the cause of this issue and will update this page when more information is available.
Posted Sep 20, 2023 - 10:40 EDT
This incident affected: CRM, Marketing Tools, Sales Tools, Service Tools, Chat & Automation, and Reports.