Past incidents Return to status page
Marketing email "Analyze" and "Performance" pages are failing to load for some customers
Incident Report for HubSpot
Resolved
This issue has been resolved and all "Analyze" and "Performance" pages are loading as expected.
Posted May 17, 2018 - 11:42 EDT
Investigating
We're currently experiencing an issue where Marketing email analyze dashboard pages and some email performance pages are failing to load. We’re actively investigating the cause of this issue and will update this page when more information is available.
Posted May 17, 2018 - 09:47 EDT