Past incidents Return to status page
Some features are currently delayed for some customers
Incident Report for HubSpot
Resolved
HubSpot is no longer experiencing delays. We've identified and addressed the cause of the delays that began at 4:17 PM EDT (UTC -04:00) on Jul 24, 2023. The issue is now fully resolved.
Posted Aug 04, 2023 - 14:03 EDT
Monitoring
We've addressed the issue that was causing slow run times starting at 4:17 PM EDT (UTC -04:00) on Jul 24, 2023. We're monitoring the tools closely to make sure all processes recover properly.
Posted Jul 31, 2023 - 09:54 EDT
Update
Some features such as lists, reports and record pages are experiencing delays in HubSpot. Our team is continuing to investigate the cause of this issue and will update this page when more information is available.
Posted Jul 28, 2023 - 11:02 EDT
Update
Some features such as lists, reports and record pages are experiencing delays in HubSpot.

Our team is continuing to investigate the cause of this issue and will update this page when more information is available.
Posted Jul 27, 2023 - 18:15 EDT
Investigating
Some features such as lists, reports and record pages in HubSpot are experiencing delays. This may impact tools such as reports, lists and record pages in HubSpot. Our team is investigating the cause of this issue and will update this page when more information is available.
Posted Jul 27, 2023 - 14:35 EDT
This incident affected: CRM, Marketing Tools, and Reports.