Past incidents Return to status page
HubSpot is currently unavailable for customers in Denmark, Sweden and others
Incident Report for HubSpot
Resolved
HubSpot software should now be working for all users from Denmark and Sweden. We’ve identified the likely cause as a localized ISP (Internet Service Provider) issue and the incident has now been resolved.
Posted Jun 29, 2020 - 07:06 EDT
Monitoring
We're receiving reports that the HubSpot is now loading successfully for users accessing it from Denmark and Sweden. We’re continuing to investigate the cause of this issue and will update this page when more information is available.
Posted Jun 29, 2020 - 06:15 EDT
Update
HubSpot is still not loading for some users accessing it from Denmark and Sweden. We’re investigating the cause of this issue and will update this page when more information is available.
Posted Jun 29, 2020 - 05:51 EDT
Investigating
The HubSpot app isn’t loading for users accessing it from Denmark, Sweden and closely located countries. We’re investigating the cause of this issue and will update this page when more information is available.
Posted Jun 29, 2020 - 05:21 EDT
This incident affected: CRM, Marketing Tools, Sales Tools, and Service Tools.