Past incidents Return to status page
Updates to published pages are currently delayed for all customers
Incident Report for HubSpot
Resolved
We've identified and addressed the cause of the delays in updates to published pages that began at 3:47 PM EST (UTC -05:00) on Dec 18, 2023. The issue is now fully resolved.
Posted Dec 18, 2023 - 20:06 EST
Identified
We’ve identified an issue that is causing delays in updates to published pages beginning at 3:47 PM EST (UTC -05:00) on Dec 18, 2023. We’re addressing the cause of this issue.
Posted Dec 18, 2023 - 19:38 EST
This incident affected: Website.