Past incidents Return to status page
Some edits are failing with marketing email, website, landing pages, and blog pages.
Incident Report for HubSpot
Resolved
We have resolved an issue that resulted in some edits to emails, website, landing, and blog pages to be delayed for a period of 15 minutes.
Posted Oct 28, 2019 - 16:05 EDT
Investigating
We're currently investigating this issue.
Posted Oct 28, 2019 - 15:35 EDT