Past incidents Return to status page
HubSpot Login is currently experiencing delays loading
Incident Report for HubSpot
Resolved
HubSpot software is now working for all users. We’ve identified and addressed the cause of the issue and the incident has now been fully resolved. We expect no long-term impact as a result of this issue and there is no action needed from our customers.
Posted Feb 06, 2020 - 12:03 EST
Monitoring
We’ve addressed the issue that’s been preventing HubSpot Login and software from loading since 10:10am ET. We’re monitoring performance to ensure the app recovers properly.
Posted Feb 06, 2020 - 11:13 EST
Investigating
HubSpot Login is experiencing delays loading for all customers. We’re investigating the cause of this issue and will update this page when more information is available.
Posted Feb 06, 2020 - 10:30 EST
This incident affected: CRM, Marketing Tools, Website, Sales Tools, Service Tools, Chat & Automation, and Reports.