Past incidents Return to status page
Issues with pages loading in HubSpot
Incident Report for HubSpot
Resolved
The issue with our data center has been resolved. Any data delays have caught up and all apps within HubSpot should be operating as normal.
Posted Jul 26, 2016 - 06:48 EDT
Monitoring
The immediate issue has been identified and resolved, but some data may still be delayed in updating.
Posted Jul 26, 2016 - 06:18 EDT
Identified
We're currently experiencing issues with one of our data centers. This is affecting all apps in HubSpot, causing pages to not load intermittently. We're working to find a a resolution as soon as possible.
Posted Jul 26, 2016 - 05:58 EDT
This incident affected: HubSpot APIs and Integrations.