Past incidents Return to status page
Form submission processing is currently delayed for some customers
Incident Report for HubSpot
Resolved
The processing of form submissions in HubSpot is now fully operational. We’ve identified and addressed the cause of the issue and the incident has now been fully resolved. No submissions were lost as a result of this issue.
Posted Mar 22, 2017 - 12:53 EDT
Update
We are currently working through a small number or remaining delayed submissions and expect to be back to real time processing for all submissions within 20 minutes.
Posted Mar 22, 2017 - 11:57 EDT
Monitoring
We’ve identified the issue that’s caused the processing of form submissions to be delayed since 8:20 pm EST on Tuesday, March 21, 2017. We have identified and addressed the root cause of the issue and are currently processing a backlog of submissions. We expect to be fully caught up with all form submissions within the next hour and will update this page when more information is available. No submissions have been lost as a result of this issue.
Posted Mar 22, 2017 - 09:46 EDT
Identified
The processing of form submissions in HubSpot is currently experiencing delays of up to 12 hours for approximately 20% of submissions, beginning at 8:20 pm EST on Tuesday, March 21, 2017. A large portion of these submissions are associated with forms pushing to integrated Salesforce campaigns. We’re actively investigating the cause of this issue and will update this page when more information is available.
Posted Mar 22, 2017 - 09:15 EDT