Past incidents Return to status page
Meeting availability is unavailable for some customers
Incident Report for HubSpot
Resolved
Google Workspace has identified and addressed the issue affecting Google Calendar. The incident has been fully resolved and calendar availability and calendar connections are working properly. No data was lost.

As part of this incident, notifications were sent to HubSpot users of impacted calendars letting them know that someone tried to book time with them. Since these meetings were not automatically booked, these users should reach out to their contact(s) to confirm their meeting time.

Additionally, prospects may not have received reminder emails for upcoming meetings. Reminders from this timeframe will not be sent retroactively, however, future reminder emails will now be sent as expected.

Google Workspace Update: https://www.google.com/appsstatus/dashboard/incidents/7uJZ5F1Uy4n1n74iMacQ
Posted Sep 21, 2023 - 13:15 EDT
Update
Google Workspace is monitoring the fix to an issue affecting Google Calendar that caused meeting availability and new calendar connections to be unavailable for some users since 9:30 AM EDT (UTC -04:00) on Sep 21, 2023. While this issue should be resolved for some users, we are continuing to check progress with Google Workspace until the issue is fully resolved. Customers who are having issues loading their calendar may be able to fix this by refreshing their browser.

Google Workspace Status Page: https://www.google.com/appsstatus/dashboard/incidents/7uJZ5F1Uy4n1n74iMacQ
Posted Sep 21, 2023 - 12:27 EDT
Monitoring
Google Workspace is monitoring the fix to an issue affecting Google Calendar that caused meeting availability and new calendar connections to be unavailable for some users since 9:30 AM EDT (UTC -04:00) on Sep 21, 2023. While this issue should be resolved for the majority of users, we are continuing to check progress with Google Workspace until the issue is fully resolved. Customers who are having issues loading their calendar may be able to fix this by refreshing their browser.

Google Workspace Status Page: https://www.google.com/appsstatus/dashboard/incidents/7uJZ5F1Uy4n1n74iMacQ
Posted Sep 21, 2023 - 12:26 EDT
Identified
Google Workspace has identified an issue affecting Google Calendar. It has caused meeting availability and new calendar connections to be unavailable for some users since 9:30 AM EDT (UTC -04:00) on Sep 21, 2023. We are monitoring progress with Google Workspace until the issue is resolved.

Google Workspace Status Page: https://www.google.com/appsstatus/dashboard/incidents/7uJZ5F1Uy4n1n74iMacQ
Posted Sep 21, 2023 - 11:42 EDT
Investigating
Some calendars are not showing correct availability when booking meetings. Some customers may see meeting requests instead of meetings being automatically booked. They may also experience errors when trying to connect a new calendar. We're investigating the issue and will update this page when we have more information.
Posted Sep 21, 2023 - 11:10 EDT
This incident affected: Sales Tools.