Past incidents Return to status page
Email statistics are currently delayed for all customers
Incident Report for HubSpot
Resolved
Email statistics in HubSpot are now fully caught up. We’ve identified and addressed the cause of the issue, and no data was lost.
Posted May 24, 2018 - 21:01 EDT
Investigating
Email statistics in HubSpot are now fully caught up. We’ve identified and addressed the cause of the issue and are working on recovering any missing data.
Posted May 24, 2018 - 21:00 EDT
Monitoring
Email statistics and analytic events in HubSpot have been experiencing delays of up to an hour since 5:05 pm ET. We’ve identified the issue that’s caused the delay. We’re actively addressing the cause of this issue and will update this page when more information is available.
Posted May 24, 2018 - 17:52 EDT