Past incidents Return to status page
HubSpot is currently unavailable for customers in Mexico
Incident Report for HubSpot
Resolved
This incident has been resolved.
Posted Jun 24, 2020 - 16:49 EDT
Monitoring
We’ve addressed the issue that’s been preventing HubSpot software from loading since 6/24/20 2:56pmEST for users accessing it from Mexico. We’re monitoring performance to ensure the app recovers properly.
Posted Jun 24, 2020 - 16:09 EDT