Past incidents Return to status page
Form submissions are currently delayed for some customers
Incident Report for HubSpot
Resolved
Form submissions are no longer experiencing delays. We’ve identified and addressed the cause of the delays that began at 4:14 PM EDT on September 29, 2022. The issue is now fully resolved. No data was lost.
Posted Sep 29, 2022 - 18:15 EDT
Monitoring
We’ve addressed the issue that caused delays in form submissions beginning at 4:14 PM EDT on September 29, 2022. No data was lost. We’re monitoring performance closely to ensure the tools recover properly.
Posted Sep 29, 2022 - 18:04 EDT
Identified
We’ve identified an issue that caused delays in form submissions beginning at 4:14 PM EDT on September 29, 2022. No data was lost. The submissions may take up to 30 minutes to show in HubSpot. Our team is addressing the cause of this issue and will update this page when the issue is resolved.
Posted Sep 29, 2022 - 17:50 EDT
This incident affected: Marketing Tools.