Past incidents Return to status page
A Chrome extension is causing loading issues for some customers
Incident Report for HubSpot
Resolved
HubSpot loading issues have now been fully resolved. No data was lost.
Posted May 23, 2023 - 09:46 EDT
Investigating
Some customers using the third-party Chrome extension, Apollo, are experiencing issues loading HubSpot. Apollo has acknowledged the issue and we will update this page when we have more information. As a workaround, customers can uninstall the Apollo extension from Chrome to resolve the issue.
Posted May 22, 2023 - 17:54 EDT
This incident affected: Integrations.