Past incidents Return to status page
HubSpot is currently unavailable for customers in our North American data center
Incident Report for HubSpot
Resolved
HubSpot software is now working for all users. We've identified and addressed the cause and the incident has now been fully resolved. No data has been lost.
Posted Nov 28, 2022 - 15:29 EST
Monitoring
We've addressed the issue that's been preventing HubSpot software from loading since 2:23 PM EST (UTC -05:00) on Nov 28, 2022 for users in our North American data center. We’re monitoring the tools closely to ensure all processes recover properly.
Posted Nov 28, 2022 - 14:53 EST
Investigating
The HubSpot app isn't loading for some customers in our North American data center. We're investigating the cause of this issue and will update this page when when we have more information.
Posted Nov 28, 2022 - 14:35 EST
This incident affected: CRM and Website.