Past incidents Return to status page
Updates to HubSpot CRM were delayed in the UI for all customers
Incident Report for HubSpot
Resolved
Updates to HubSpot CRM were experiencing some delays in the UI on 2/11/2019 between 2:30PM ET and 3:20PM ET. Contact creation may have experienced some failures as well. We've identified and addressed the cause of this issue and the incident has now been fully resolved.
Posted Feb 11, 2019 - 15:30 EST
This incident affected: HubSpot APIs.