Past incidents Return to status page
Some HubSpot applications and services are intermittently unavailable for some customers
Incident Report for HubSpot
Resolved
At this time, all HubSpot applications and services are functioning normally. Thank you for your patience as we worked with our providers towards a fix. Now that systems are back in working order, our infrastructure and engineering teams will review what happened to look for ways to improve the availability and performance of our products. From there, we will put a plan in place to make it easier for us to recover from future critical outages with our service providers. Thanks again for your understanding, and for using HubSpot.
Posted Feb 28, 2017 - 19:45 EST
Update
CRM email logging is now caught up for all users, and nearly all HubSpot applications and services are functioning normally. Analytics event processing is still delayed by a few hours, but should catch up over the next few hours.
Posted Feb 28, 2017 - 18:49 EST
Monitoring
HubSpot applications and services are nearly all functioning normally across the board. Analytics event processing is still lagged by a few hours but should catch up over the next few hours. There may also be a very small number of users which are seeing delays associated with logging emails inside the CRM, but they should be caught up momentarily.
Posted Feb 28, 2017 - 17:41 EST
Update
Email delivery is now caught up. We are still working on processing through the backlog of sending via a connected account, sequences, send later, and reply tracking inside the HubSpot CRM and Sales products.
Posted Feb 28, 2017 - 17:24 EST
Update
At this time, contact imports and file uploads are functional and email delivery continues to work through a substantial backlog. We will continue to monitor and update this issue.
Posted Feb 28, 2017 - 17:12 EST
Update
Our service provider continues to report improvements and our engineering team is assessing impact for the HubSpot tool.

Among the affected tools, Email delivery has resumed and will be working through a substantial backlog, Analytics has begun collecting data as of 3:45pm, and all but a small percentage of public content is now available. Contact Imports and File Uploads remain affected by the service outage. We will continue to monitor and update this issue.
Posted Feb 28, 2017 - 16:25 EST
Update
Our service provider has isolated the potential root cause and is actively working on implementing what they believe will alleviate the issue. HubSpot's engineering team continues to monitor progress and assist where possible.
Posted Feb 28, 2017 - 14:51 EST
Update
Due to a widespread outage in one of our service providers, parts of the HubSpot application and services are intermittently unavailable. Email sending is unavailable as a result and emails will be sent once the service is available. Engineering is actively investigating the issue.
Posted Feb 28, 2017 - 13:42 EST
Identified
Due to a widespread outage in one of our service providers, parts of the HubSpot application and services are intermittently unavailable. Files are not able to upload and some images are failing to load. Engineering is actively investigating the issue.
Posted Feb 28, 2017 - 13:09 EST
Investigating
Investigating
We’re currently experiencing an issue that’s preventing the HubSpot app from loading for some users. Assets on web pages, file manager uploads, and images are not loading as well. We’re actively investigating the cause of this issue and will update this page when more information is available.
Posted Feb 28, 2017 - 13:05 EST