Past incidents Return to status page
Creation and Editing of emails/pages/blogs is experiencing temporary issues.
Incident Report for HubSpot
Resolved
Creation and Editing of emails/pages/blogs experienced temporary issues today from 5am to 7am EST. This has now been fully resolved and all editors are working correctly.
Posted Mar 20, 2017 - 07:13 EDT
Investigating
Some customers may see errors when using email/pages/blogs, especially when creating or editing content. We are currently investigating this and will have an update shortly.
Posted Mar 20, 2017 - 06:57 EDT