We've addressed the issue that caused multiple apps to be partially unavailable. HubSpot is working properly and the incident has been fully resolved.
Posted Oct 21, 2025 - 04:09 EDT
Monitoring
We've addressed the issue that caused reporting to be partially unavailable in North America since 09:03 AM (UTC -04:00). We're monitoring performance closely to ensure the tools recover properly.
The information on this page reflects our understanding of the incident and impact at the time of the update.
Posted Oct 20, 2025 - 18:25 EDT
Update
Multiple apps, including Reporting, are unavailable for our customers in North America. We continue to work with our cloud platform provider, AWS, to resolve this issue (https://health.aws.amazon.com/health/status). We will be back with an update within 30 minutes.
Posted Oct 20, 2025 - 17:39 EDT
Update
Multiple apps, including Reporting and Developer Tools, are unavailable for our customers in North America. We continue to work with our cloud platform provider, AWS, to resolve this issue (https://health.aws.amazon.com/health/status). We will be back with an update within an hour.
Posted Oct 20, 2025 - 16:25 EDT
Update
Multiple apps, including Reporting and Developer Tools, are unavailable for our customers in North America. We continue to work with our cloud platform provider, AWS, to resolve this issue (https://health.aws.amazon.com/health/status). We will be back with an update within 30 minutes.
Posted Oct 20, 2025 - 15:36 EDT
Update
Multiple apps, including Reporting and Developer Tools, are unavailable for our customers in North America. We continue to work with our cloud platform provider, AWS, to resolve this issue (https://health.aws.amazon.com/health/status). We will be back with an update within 30 minutes.
Posted Oct 20, 2025 - 15:05 EDT
Update
Multiple apps, including Reporting and Developer Tools, are unavailable for our customers in North America. We continue to work with our cloud platform provider, AWS, to resolve this issue (https://health.aws.amazon.com/health/status). We will be back with an update within 30 minutes.
Posted Oct 20, 2025 - 14:37 EDT
Update
Multiple apps, including Reporting and Developer Tools, are unavailable for our customers in North America. We continue to work with our cloud platform provider, AWS, to resolve this issue (https://health.aws.amazon.com/health/status). Only customers hosted in North America are currently impacted. We will be back with an update within 30 minutes.
Posted Oct 20, 2025 - 13:54 EDT
Update
Multiple apps, including Reporting and Developer Tools, are unavailable for our customers in North America. We continue to work with our cloud platform provider, AWS, to resolve this issue (https://health.aws.amazon.com/health/status). We will be back with an update within 30 minutes.
Posted Oct 20, 2025 - 13:25 EDT
Update
Multiple apps, including Reporting and Developer Tools, are unavailable for our customers in North America. We continue to work with our cloud platform provider, AWS, to resolve this issue (https://health.aws.amazon.com/health/status). We will be back with an update within 30 minutes.
Posted Oct 20, 2025 - 12:46 EDT
Update
Multiple apps, including Reporting and Developer Tools, are unavailable for our customers. We continue to work with our cloud platform provider, AWS, to resolve this issue (https://health.aws.amazon.com/health/status). We will be back with an update within 30 minutes.
Posted Oct 20, 2025 - 12:11 EDT
Update
We found the issue causing reporting and Snowflake exports to be down since 9:03 AM EDT on Oct 20, 2025. We continue working with our partners, Snowflake, AWS, to resolve the issue, and will share an update within 30 minutes. Only customers hosted in North America are currently impacted. https://status.snowflake.com/incidents/gvmvnx7lyxjj
Posted Oct 20, 2025 - 11:36 EDT
Update
We found the issue causing reporting and Snowflake exports to be down since 9:03 AM EDT on Oct 20, 2025. We will continue working with our partner, Snowflake, to resolve the issue, and will share an update within 30 minutes. Only customers hosted in North America are currently impacted.
We found the issue causing reporting and Snowflake exports to be down since 9:03 AM EDT on Oct 20, 2025. We continue working with our partner, Snowflake, to resolve the issue, and will share an update within 30 minutes. Only customers hosted in North America are currently impacted.
We found the issue causing reporting and Snowflake exports to be down since 9:03 AM EDT on Oct 20, 2025. We’re working with our partner, Snowflake, to resolve the issue and will share an update within 30 minutes. Only North American customers are affected.