Past incidents Return to status page
Cross Object Reports are delayed or failing for some HubSpot users.
Incident Report for HubSpot
Resolved
All Cross Object Reports are no longer experiencing delays and are working as expected. No data has been lost.
Posted May 05, 2021 - 14:25 EDT
Monitoring
Cross Object reports are no longer experiencing delays. Other report types were not impacted, and no data has been lost.

We’re monitoring the tools closely to ensure all processes recover properly.
Posted May 05, 2021 - 12:02 EDT
Investigating
Beginning April 29, Cross Object Reports in HubSpot are experiencing intermittent delays or failures. This may impact the ability to create, or load Cross Object Reports, export reports, and some reports may show incomplete data. Other report types are not impacted, and no data has been lost. If you need data from reports, the new Custom Report Builder is working as expected and allows for reporting on 2+ objects.: https://app.hubspot.com/l/advanced-builder
Posted May 05, 2021 - 10:11 EDT
This incident affected: Reports.