Past incidents Return to status page
Customers are not able to reset their passwords right now
Incident Report for HubSpot
Resolved
Password reset emails did not send between 8:45 AM and 9:55 AM EST, so customers were unable to reset their passwords. This issue is now fully resolved, and customers can reset their passwords.
Posted Jun 16, 2021 - 09:56 EDT
Investigating
Password reset emails have not been sending since 8:45 AM EST, so customers cannot currently reset their passwords. Our team is investigating the cause of this issue and working to resolve it as quickly as possible. We'll update this page as more information becomes available.
Posted Jun 16, 2021 - 09:29 EDT