Past incidents Return to status page
HubSpot is currently unavailable for some customers
Incident Report for HubSpot
Resolved
HubSpot software is now working for all users. We've identified and addressed the cause of the issue and the incident has now been fully resolved. No data was lost.
Posted Sep 18, 2024 - 10:31 EDT
Monitoring
We've addressed the issue that's been preventing HubSpot software from loading since 8:33 AM EDT (UTC -04:00) on Sep 18, 2024 for some users. We’re monitoring the tools closely to make sure all processes recover properly.
Posted Sep 18, 2024 - 09:32 EDT
Investigating
The HubSpot app isn't loading for some customers. We're investigating the cause of this issue and will update this page when we have more information.
Posted Sep 18, 2024 - 08:50 EDT