Past incidents Return to status page
Delay in HubSpot Marketing Product Forms Processing
Incident Report for HubSpot
Resolved
As of 6:00PM EST we have fully resolved the issue that was causing a delay in HubSpot Marketing Product forms processing. No data was lost during this delay and at this point all forms are processing normally.
Posted Jul 20, 2016 - 18:06 EDT
Identified
We are currently investigating and have identified an issue that is causing a delay in HubSpot form submission processing in HubSpot's marketing product. We are working on a resolution to the underlying issue right now and will update with more information soon.
Posted Jul 20, 2016 - 17:44 EDT