Past incidents Return to status page
HubSpot Calling is currently unavailable for all customers
Incident Report for HubSpot
Resolved
Calling in HubSpot is now fully operational. We’ve identified and addressed the issue that caused calling to be unavailable from 12:09 PM to 12:52 PM.
Posted Nov 21, 2019 - 13:18 EST
Monitoring
We’ve addressed the issue that’s caused calling in HubSpot to be unavailable. We’re monitoring performance to ensure the process recovers properly.
Posted Nov 21, 2019 - 12:55 EST
Identified
We’ve identified the issue that’s caused calling in HubSpot to be unavailable. We’re addressing the cause of this issue and will update this page when more information is available.
Posted Nov 21, 2019 - 12:48 EST
This incident affected: CRM and Sales Tools.