Email Sending is no longer experiencing delays. We've identified and addressed the cause of the delays that began at 11:00 AM EDT (UTC -04:00). As of 1:55 PM EDT all previously delayed emails have been sent.
Posted 13 days ago. Mar 27, 2025 - 14:00 EDT
Monitoring
We have addressed the issue that was causing email sends to be delayed. All new email sends are fully recovered. We continue to process through the backlog of delayed emails, which still has a delay of around an hour, but is actively recovering. We will be back with an update within an hour.
Posted 13 days ago. Mar 27, 2025 - 13:28 EDT
Update
We are continuing to investigate the root cause into why emails within our North America infrastructure are currently delayed. We continue to operate with a delay of around an hour for outbound emails. We will be back with an update within an hour.
Posted 13 days ago. Mar 27, 2025 - 13:11 EDT
Update
We've identified an issue within our system that is delaying some email sends within our North America infrastructure. This is impacting about half of all email sends now, which are seeing delays of around an hour. We are working to address the root cause. We will be back with an update within an hour.
Posted 13 days ago. Mar 27, 2025 - 12:13 EDT
Investigating
Email Sending in HubSpot is experiencing delays. Our team is investigating the cause of this issue and will update this page when more information is available. We will be back with an update within 30 minutes.
Posted 13 days ago. Mar 27, 2025 - 11:58 EDT
This incident affected: Marketing Tools and Sales Tools.